
Features & Enhancements 

• Duplicate Selected Clip(s) (CTRL+D or Track view Clips > Duplicate Selected Clip(s) 

command). 
• Auto Crossfade toggle in Track view. 

• Show note names on Piano Roll view Note events (PRV Notes > Show Note Names). 

• Take lane record options available form Record button context menu and Edit > 

Preferences > Project - Record: ‘Create New Lane’, ‘Reuse Existing Lane’, and ‘Reuse 
Existing Lane, Unless Takes Overlap’. 

• Take lane enhancements: 

• Import directly to Take lanes from  File > Import and double-clicking in Media Browser. 

• Fast Edit filter switching (SHIFT+right-click). 

• Change fade type on crossfaded clips. 

• CTRL+ALT+drag adjusts a single crossfade. 

• Hold SHIFT and drag a clip edge to crop an individual clip. 

• Holding SHIFT on Comp track (lanes collapsed) now allows for adjusting split location 

across lanes. 
• Play List enhancements, including option to defer loading the next song until after the 

current song has finished, option to close projects regardless of project changes, and Help 
Module content. 

• New keyboard shortcuts: Insert Audio track (CTRL+T), Insert MIDI track 

(CTRL+SHIFT+T), Clear Selection (SHIFT+ESC), and Redo (CTRL+Y). 
• Mackie Control enhancements, including HUI protocol support, support for alternative 

parameter labels, and support for ProChannel EQ, Track Compressor, and Bus Compressor. 
• Improvements to plug-in state loading and presets. 

• Support for VST2 plug-ins without binary block persistence, which allows Cakewalk to 

properly restore parameters for such plug-ins when loading projects. 
• Support for VST3 Program Changes. Cakewalk now supports changing programs for VST3 

plug-ins via a new Program change parameter. There is now a Preset value at the end of the 
automation parameter list that will change plug-in preset values for plug-ins that support it. 

• Overhaul of plug-in time sync in engine. There has been an overhaul of the engine to 

improve and optimize time sync with plug-ins. The changes improve the accuracy of time 
synchronization while seeking on the timeline during playback and while looping. We also 
addressed known problems with time sync with Melodyne and other time dependent plug-
ins that have an internal timeline. 

• Improved Reset/Panic to clear stuck MIDI notes, and CTRL+click Reset button to force a 

reload of the audio and MIDI engine. 
• Support for ‘stop’ and ‘pause’ MCI MIDI events to automatically stop/pause playback 

• Improved compatibility with older SONAR WRK files. 

• Updated ‘Basic’ Lens that provides a cleaner and simplified layout.  



• Dropout Analytics: Dropouts are now flagged with a reason code (listed in the dropout 

message) that can be useful in tracking down the cause of dropouts. The online help lists the 
dropout reason codes and potential preventative action that may be taken.  

Behavior changes 

• When isolating clips in Take lanes during playback, the Now time jumps to the clicked 

location by default. To automatically jump to the clip start instead, enable the Track view 
Options > Click Behavior > Left Click Rewinds to Clip Start in Lanes option. This 
option replaces the previous SHIFT-click behavior. 

• The Track view Options > Click Behavior > Left Click Sets Now option only sets the now 

time during playback when using the Smart tool, Comping tool, or Move tool (when 
clicking whitespace only). All other tools do not set the Now time when clicking in the Clips
pane. 

• By default, the Play List no longer prompts to save project changes during playback. 

• SHIFT+double-clicking a clip no longer hides other tracks. 

• CTRL+T shortcut is now ‘Insert Audio Track’ instead of ‘Hide tracks not in selection’. 

• Edit > Paste no longer uses settings from the Edit > Paste Special dialog box. The use the 

Paste Special settings, go to Edit > Preferences > Customization - Editing and select Use 
Paste Special Options on Paste. 

• SHIFT+Z shortcut is no longer assigned to the Track view View > Auto Track Zoom 

command by default. The Auto Track Zoom command can be assigned to any shortcut in
 Edit > Preferences > Customization - Keyboard Shortcuts. 

• The RTZ command has been renamed to Rewind to Landmarks. 

• The Go to Beginning (1:1:0) command has been renamed to Go to Start (RTZ). 

• The Go to Start (RTZ) and Go to End buttons now accurately seek to project beginning 

and end, and do not stop playback. 
• The Go to Start transport button uses the CTRL+HOME shortcut. 

Optimizations 

• Improved application startup time especially when many 32-bit plug-ins are present. 

• Improved efficiency when playing back or looping projects with lots of plug-ins at low 

latency. 
• Faster loading of project files containing many plug-ins and synths.  

• Switching plug-in presets is faster. 

• Exporting or bouncing projects containing clips stretched using élastique audio is faster, 

because stretches are no longer pre-processed prior to rendering.
  

Bug Fixes 

Stability 



• All reports of loss of plug-in states when loading projects have been addressed. 

• Intermittent crashes when adding plug-in side-chains were fixed. 

• Setting Track Input to same Patch Point as Output crashes. Patch points have been removed 

from dropdown in Selected Track Inputs dialog box. 
• Focusrite ASIO Devices could create a buzzing sound when stopping playback rapidly. 

• Some ASIO devices could result in unstoppable playback when stopping and starting the 

transport rapidly. 
• Improved ASIO first buffer processing when starting playback. 

• User reported ASIO crash on playback start. 

• User reported Crash when deleting MIDI track. 

• Rapidly stopping and starting playback could rewind the transport unexpectedly. 

• Crash editing plug-in automation envelope during playback. 

• Some plug-in’s such as Acorn Digital could cause a hang when changing presets. 

• Edit commands to ‘delete hole’ or ‘slide to make room’ could occasionally have unexpected 

results. These commands now use standard ripple edit behavior. 
• Some legacy .WRK files could cause a hang when attempting to open them. 

• Adding a synth in the FX Rack could cause all plug-in automation to get orphaned on next 

load of the project. 
• Hang when rapidly clicking Track view menu bar buttons. 

• Patch points or Aux tracks could cause a memory leak leading to a dropout. 

UI 

• Progress bar in Control Bar Transport module flashes black. 

• Help Module doesn't update if floating and the Browser is collapsed. 

• Layout issues when changing CPU Meter options in Control Bar Performance module 

• Num 0 is shown as ‘Unassigned’ in Preferences > Customization - Keyboard Shortcuts. 

• Audio is not shown on initial launch of Drum Replacer 

• New Project dialog box draws incorrectly when Play List is open. 

• Undo of Insert Effect does not remove assigned sends. 

• Rapidly pressing SPACEBAR to start and stop playback with On stop, Rewind to Now 

Marker selected has unexpected results. 
• Play List controls do not show info in the Help Module. 

• Selection shading in time ruler does not update in real-time when moving selection handles.

  

Selection/Tools 

• Tools with specific hit zones do not leverage extra space when other Smart tools behaviors 

are disabled. 

Take Lanes/Comping 



• Manually healing abutting healable clips (hold down the CTRL key and click one of the 

selected clips) in Take lanes ignores the selection. 
• Comp clip doesn’t show range selection. 

• SHIFT+right-click does not toggle Edit Filter in lanes. 

• File > Import > Audio does not place clip on selected lane. 

• Double-click import from Media Browser does not respect lane selection. 

• It’s possible to set a parent track’s Edit filter to Audio Transients or Clip Automation when

Take lanes are visible. 
• Moving Clips in lanes with Slide Over Old to Make Room selected causes unexpected 

results. 
• Slip-editing no longer works in lanes unless SHIFT is pressed. 

• Comp clips show data from muted MIDI clips. 

• Comp clip draws waveform amplitude incorrectly after deleting clip selections from Take 

lanes. 
• Holding down the CTRL key while using the Smart tool or Comping tool in Take lanes does 

not toggle clip mute state consistently. 
• Speed comping is unnecessarily healing clips during, resulting in unexpected clip cropping. 

Automation 

• Drawing automation with the Freehand tool creates unexpected envelope nodes when 

dragging outside the Automation lane boundary. 
• Automation lane parameter slider shows cut off text. 

• When Automation lanes are minimized, the slider value overlaps the slider. 

• When dragging a Comp clip to a new project, automation may or may not be copied 

depending on where the clip is clicked and dragged from. 
• Loop recording automation preview does not work as expected after it loops back. 

Track View 

• Aim Assist is visible on app startup when mouse isn't over Clips pane. 

• Aim Assist line remains visible outside of the Clips pane in some circumstances. 

• Track folders show open/close (+/-) toggle when folders are empty. 

• Waveform Preview obscures automation in buses and tracks. 

• Groove clips show snap offsets (anchor points) when dragging. 

• The background color of clips showing clip envelopes changes unexpectedly after 

performing a Cut, Paste, then Undo twice. 
• Multi-clip slip stretching allows clips to be stretched before measure 1. 

• Bus waveform preview does not draw properly in response to volume changes. 

• When switching tools with a modifier shortcut, the mouse cursor does not update until 

moved. 
• Cancelling a Clips pane drag operation clears the selection. 

• When clips are split, the clip selection changes, but the Time Ruler selection does not update

to match. 



• Preview is not shown when drag-copying a position locked clip. 

Piano Roll view 

• Dragging from right to left in the Time Ruler to make a selection can cause unexpected 

selection drawing in the Piano Roll view. 
• Aim Assist does not refresh immediately in the Piano Roll view Time Ruler after 

disabling/enabling. 
• Piano Roll view track focus does not persist in screensets. 

• Zooming the Piano Roll view with CTRL+ALT+mouse wheel produces drawing artifacts in 

the Time Ruler. 
• Piano Roll view keys are grayed out indefinitely if Note Off not sent by MIDI controller. 

• Piano Roll view does not show correct track colors when dragging notes from multiple 

tracks. 

Plug-ins 

• Plug-ins can lose state and revert to the plug-in reset state if changes are made when the 

plug-in is not active. 
• When loading plug-ins from a saved FX Chain preset, the values can get reset when 

dragging between FX Racks. 
• Bank Select messages are not sent to VST 2 plug-ins. 

• Opening some plug-in windows automatically mark the project as modified.. 

• 32-bit VST plug-ins are not hidden when 64-bit equivalents are available 

• App startup time is very slow when many 32-bit plug-ins are present in the VST inventory. 

• External Insert can be added to clips FX Rack from MRU list. 

• VST2 plug-ins that do not support binary block persistence, and do not have default 

programs, do not save their state and reset to default on open. 
• Projects with older Arturia plug-ins like Piano V load but plug-ins are silent. 

General fixes 

• Cakewalk must be periodically activated via BandLab Assistant, but will no longer switch to

demo mode during a session. A notification will remind you 14 days before the application 
needs to be reactivated. 

• Opening Melodyne clip does not select clip in Melodyne. 

• Melodyne loses sync with metronome count-In. 

• Melodyne loses sync when seeking on timeline. 

• Loop playback of Melodyne loses sync when seeking on timeline. 

• Drum Replacer loses sync when seeking on timeline. 

• Cloning a track inside a Track Folder sometimes places the new track outside the folder. 

• Intermittent “motorboating” during playback with Focusrite devices. 

• MIDI playback can lose sync when seeking in a project that contains tempo changes. 

• When using a split instrument track, setting the audio output track's Input to 'None' does not 

disable Input Echo. 



• Old Cakewalk .WRK files referencing MCI audio events fail to open. 

• Installer does not overwrite existing Help Module content. 

• Update Installer is not replacing CW130Auto.dll. 

• Stuck MIDI notes are not reset for many softsynths by pressing the Reset button. 

• Unexpected spike in audio at edit points when using élastique Pro as Offline render mode. 

Editing and Comping Enhancements 

  

Duplicate Selected Clip(s) 

You can quickly duplicate the selected clip(s) with any of the following gestures: 

• Press CTRL+D 

• Click the Track view Clips menu and select Duplicate Selected Clip(s) 

• Right-click in the Clips pane and select Duplicate Selected Clip(s) on the pop-up menu 

The following rules apply when duplicating clips: 

• Only events and clip automation are copied. 

• The new clip(s) will be pasted immediately after the existing clip(s), respecting the current 

Ripple Edit settings. 
• To respect the current Snap to Grid settings, go to Edit > Preferences > Customization - 

Editing and select Use Current Snap Settings on Duplicate Selected Clip(s). 
• After duplication, the Now time is forwarded to the end of the duplicate (with the duplicate 

selected), so you can press CTRL+D again to make multiple duplicates 
• Unlike a normal paste, the current track will have no bearing on where the duplicates are 

pasted. Duplicates will always appear on the same tracks/lanes as the source selection. 

Tip: If you want to quickly create many repetitions, use the Edit > Copy and Edit > Paste Special 
commands. 

Paste / Paste Special behavior change 
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In the previous versions of Cakewalk, settings in the Paste Special dialog box (Edit > Paste 
Special or CTRL+ALT+V) would persist for the remainder of the Cakewalk session and apply 
when you used the regular Edit > Paste (or CTRL+V) command. As a result, normal paste could 
potentially create multiple repetitions inadvertently. By default, normal paste no longer remembers 
the settings from the Paste Special dialog box, so you will only get one copy. To remember the 
Paste Special settings, go to Edit > Preferences > Customization - Editing and select Use Paste 
Special Options on Paste. 

  

Take lane record options 

You now have improved control over how new Take lanes are created during recording. The 

following options are available from the Record button  context menu and Edit > Preferences
> Project - Record: 

• Create New Lane.    Always create a new lane for each take. 

• Reuse Existing Lane.    Reuse existing lanes for each take (this option is not available when

using the Comping record mode). 
• Reuse Existing Lane, Unless Takes Overlap.    Reuse existing lanes for each take, and 

only create new lanes if takes overlap. 

  

Import directly to Take lanes 

File > Import > Audio and double-clicking to import from the Media Browser now respect the 
selected Take lane. 

  

Fast Edit filter switching in Take lanes 

You can now use SHIFT+right-click to toggle the Edit Filter in lanes. 
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New key modifiers for edits in Take lanes 

• CTRL+ALT+drag adjusts a single crossfade 

• Hold SHIFT and drag a clip edge to crop an individual clip 

• Holding SHIFT on Comp track (lanes collapsed) now allows for adjusting split location 

across lanes 

  

Change fade type on crossfaded clips in Take lanes 

Cakewalk now allows for the adjustment of fade types (Linear, Slow Curve, or Fast Curve) for clips
in Take lanes. Right-click the top part of a clip fade to show the curve type pop-up menu. 

  

Use ripple edit for copy/paste/cut 

Cakewalk now uses ripple editing (Ripple Edit Selection) during Edit > Paste Special when Slide 
Over Old to Make Room is selected, and during Edit > Cut Special when Delete Hole is 
selected.  

  

SHIFT+double-clicking a clip no longer hides other tracks 

SHIFT+double-clicking a clip maximizes the clip, but no longer hides other tracks. This allows you 
to still show other tracks by scrolling or zooming the Track view vertically. 

  

SHIFT+ESC to clear selection 

In addition to clicking an empty space to clear the current selection in the Track view, you can now 
also press SHIFT+ESC. 

  

CTRL+Y to redo 

In addition to CTRL+SHIFT+Z, you can now also use the standard Windows redo keyboard 
shortcut CTRL+Y. 
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Stability 

• All reports of loss of plug-in states when loading projects have been addressed. 

• Intermittent crashes when adding plug-in side-chains were fixed. 

• Setting Track Input to same Patch Point as Output crashes. Patch points have been removed 

from dropdown in Selected Track Inputs dialog box. 
• Focusrite ASIO Devices could create a buzzing sound when stopping playback rapidly. 

• Some ASIO devices could result in unstoppable playback when stopping and starting the 

transport rapidly. 
• Improved ASIO first buffer processing when starting playback. 

• User reported ASIO crash on playback start. 

• User reported Crash when deleting MIDI track. 

• Rapidly stopping and starting playback could rewind the transport unexpectedly. 

• Crash editing plug-in automation envelope during playback. 

• Some plug-in’s such as Acorn Digital could cause a hang when changing presets. 

• Edit commands to ‘Delete Hole’ or ‘Slide Over Old to Make Room’ could occasionally have

unexpected results. These commands now use standard ripple edit behavior. 
• Some legacy .WRK files could cause a hang when attempting to open them. 

• Adding a synth in the FX Rack could cause all plug-in automation to get orphaned on next 

load of the project. 
• Hang when rapidly clicking Track view menu bar buttons. 

• Patch points or Aux tracks could cause a memory leak leading to a dropout.

  

Plug-ins 

  

Improvements to plug-in state loading and presets 

Saving and loading plug-in states and presets has been streamlined and greatly improved and 
simplified to prevent unexpected interactions with some third party plug-ins. By preventing 
redundant plug-in parameter updates, plug-ins and synths now load faster when opening project 
files.  

A few users previously reported intermittent cases where plug-in settings could be lost when 
changing plugin presets, copying FX chains or when loading projects. All such reported cases of 
this problem have been thoroughly investigated and addressed so these problems should no longer 
recur. 

Support for VST3 Program Changes 

• Cakewalk now supports changing programs for VST3 plug-ins via a new Program change 

parameter. There is now a Preset value at the end of the automation parameter list that will 



change plugin preset values for plugins that support it. NOTE: This Preset parameter is only 
displayed for plug-ins that expose VST3 program changes to the host. (It may not always be 
named “Preset”) 

• Waves plug-ins support the new program change parameter. 

• The new Preset parameter can be automated via envelopes.  

• For supported VST3 plug-ins, program changes can be done during playback via MIDI 

messages. To do that you must enable Translate Program Changes in the plug-in properties 
first and then restart the app. 

• For some plug-ins, program changes can be expensive. Don’t use sweeps to automate the 

program change parameter. Instead use jump events or linear sections. 

Overhaul of plug-in time sync in engine
There has been an overhaul of the engine to improve and optimize time sync with plug-ins. The 
changes improve the accuracy of time synchronization while seeking on the timeline during 
playback and while looping. We also addressed known problems with time sync with Melodyne and
other time dependent plug-ins that have an internal timeline.  

Support for VST2 plug-ins without binary block persistence
There are a few VST2 plug-ins that do not support binary block persistence. E.g. VCV Rack. 
Cakewalk now properly restores parameters for such plug-ins when loading projects
  

Optimizations 

The overhaul of plug-in time sync in the engine improved the efficiency when playing back or 
looping projects with lots of plugins, by eliminating many unnecessary and costly time unrolling 
conversions. This should yield moderate CPU gains while playing or looping projects at low latency
with lots of plugins, since the plug-in time conversions are now optimized. 

By preventing redundant plug-in parameter updates, plug-ins and synths now load faster when 
opening project files. 

Faster loading of project files containing many plug-ins and synths. 
Switching plug-in presets are now faster since there are fewer parameter updates. 

Exporting or bouncing projects containing clips stretched using élastique audio is faster, because 
stretches are no longer pre-processed prior to rendering. 

  

UI Updates 

Auto Crossfade toggle in Track view 



In addition to the Track view Options menu, you can now also enable/disable Automatic Crossfade 

via the new Automatic Crossfade button   in the top right corner of the Track view. You can 
also right-click or long press the button to specify the default crossfade type. 

  

Piano Roll view Note names 

Note events in the Piano Roll view can optionally show note names (pitch or custom note names 
from instrument definitions). To show note names, click the Piano Roll view Notes menu and select
Show Note Names. 

Note: Note names automatically hide at low zoom levels. 

  

Piano Roll view shows correct note colors while dragging 

Previously, all notes were always shown in the same red color while dragging. When dragging notes
from multiple tracks, it was difficult to know which track a note lived in. Notes are now drawn 
using the correct track color.
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Updated ‘Basic’ Lens 

The Basic lens has been updated to provide a cleaner and simplified layout.  

Note: Updated factory lenses and Help Module content are now copied to the user folder during 
installation.
  

Insert Audio track and MIDI track shortcuts
You can now quickly insert a new audio or MIDI track by using the following keyboard shortcuts: 

• Insert Audio Track = CTRL+T 

• Insert MIDI Track = CTRL+SHIFT+T 

Note: CTRL+T was previously assigned to Hide tracks not in selection. 

  

Updated transport behaviors 

• Go to Start and Go to End buttons now accurately seek to project beginning and end, and 

do not stop playback. 
• The W (rewind) key always seeks backwards in time to the prior "landmarks". There are 3 

landmarks: 
• the original playback start time 

• the loop start time 

• the project start time (time 0, or 1:1:0) 

Note: 
The RTZ command has been renamed to Rewind to Landmarks
The Go to Beginning (1:1:0) command has been renamed to Go to Start (RTZ)
The Go to Start transport button uses the CTRL+HOME shortcut 
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Click Behavior 

‘Left Click Rewinds to Clip Start in Lanes’ option 

When isolating clips in Take lanes during playback, the Now time jumps to the clicked location by 
default. To automatically jump to the clip start instead, enable the Track view Options > Click 
Behavior > Left Click Rewinds to Clip Start in Lanes option. 

Note: This option replaces the previous SHIFT-click behavior.
  

‘Left Click Sets Now’ option behavior change 

The Track view Options > Click Behavior > Left Click Sets Now option only sets the now time 
during playback when using the Smart tool, Comping tool, or Move tool (when clicking whitespace 
only). All other tools do not set the Now time when clicking in the Clips pane. 

  

Improved Reset/Panic 

The Reset button  in the Transport Control Bar module now clears stuck MIDI notes on virtual 
instruments more reliably. 

In previous versions of Cakewalk, both hardware MIDI outputs and virtual instruments shared the 
same reset method, which used controller 123 (all notes off) by default. VST3 as well as some 
VST2 soft synths don’t respond to controller 123, and instead require individual note off messages 
in order to clear stuck notes. 

In Cakewalk 2019.09, the Reset button sends both controller 123 and individual note off messages 
to soft synths. For hardware MIDI outs, if necessary you can use the PanicStrength Cakewalk.ini 
variable to specify the default behavior: 

PanicStrength=0 (controller 123; default)
PanicStrength=1 (individual note off; slower)
  

Force a reload of the audio and MIDI engine 

To force a restart of the audio and MIDI engine (only if the transport is not playing/recording), 
including a reset of ASIO, hold down the CTRL key and click the Reset button in the Transport 
Control Bar module.

  

Mackie Control enhancements 
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This release features many significant enhancements to the Mackie Control surface, including: 

• ProChannel EQ, Track Compressor & Bus Compressor support 

• Korg nanoKONTROL Studio support for Select button, Buses/Track selection 

• HUI Protocol support 

• Disable Handshake option for surfaces which only support the newer MCU protocol 

• Automatic Fader assignment based on order added within preferences 

• Key press support for function buttons / footswitches 

• Added button mappings 

• Updated command list to match Cakewalk's internal list 

Support for alternative param labels 

You can now specify alternative label names for your parameters within MackieControl.ini. This 
may be useful if the automatic abbreviated 6 character label isn’t as readable as you’d like. 

The alternative labels are still limited to 6 characters (as this is the limit of characters for each strip 
on the Mackie devices), but you can now specify your own by adding them to the bottom of each 
plugin section in the following format:  

VPotLabeln=p,name 

Where: 

n = the number of the vpot
p = the number of the VST parameter whose label you which to override
name = the new label 

e.g. 

VPotLabel0=17,HiGain
VPotLabel1=18,HiFreq
M1VPotLabel2=19,Hi Q
  

Acknowledgements:
Thanks to the contributions of @msmcleod as well as forum member @azslow3 for fixes to the 
Mackie control DLL in our opensource GitHub project. 

  

Improved audio dropout diagnosis 

Dropouts can occur for a variety of reasons, not just CPU load. We’ve added useful information to 
help you diagnose the cause of a dropout. When a dropout occurs, playback stops and a toast 
notification will show the detected dropout reason code. This code can be useful in tracking down 
the reason for dropouts. 

https://github.com/Cakewalk/Cakewalk-Control-Surface-SDK
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Below are some of the most common dropout reason codes along with potential preventative action 
that may be taken: 

Code  Reason for dropout Potential preventative action 

0 
Unknown error or no dropout   

1 

Audio processing took longer 
than the buffers allotted 
timeslice 

Increase the Buffer Size value in Edit > 
Preferences > Audio - Driver Settings. 

2 

Buffer underrun while 
processing or error writing 
record buffers 

Possible CPU overload or driver malfunction. 
Increase latency and check disk status. 

3 

WDM/MME/WASAPI drivers 
audio buffers not delivered for 
over DropoutMsec 
milliseconds 

Increase the DropoutMsec variable value in 
AUD.ini, which lets you configure the tolerance 
time in milliseconds before dropping if the audio 
pump mechanism becomes starved (default is 250 
ms). 

4 

WDM/MME/WASAPI output 
buffer not available for delivery
to audio device 

Increase the Buffers in Playback Queue value in 
Edit > Preferences > Audio - Driver Settings. 

5 

Disk reading overloaded and 
could not keep up with 
playback pump 

Increase the Playback I/O Buffer Size value in 
Edit > Preferences > Audio - Sync and Caching. 

6 
[Internal] Error filling disk 
playback buffer cache 

Disk may be full condition or disk read error. 
Check disk status. 

7 
[Internal] Error reading from 
disk playback buffer cache 

Possible memory corruption. Close and restart the 
application then reload the project. 

8 Disk write error Disk full or error writing record wave files. Free up
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some disk space. 

9 
Sequencer MIDI pump 
underrun 

Increase the Prepare using n Millisecond Buffers 
value in Edit > Preferences > MIDI - Playback 
and Recording. 

10 
[Internal] Audio pump 
frequency problem 

  

11 
[Internal] Unexpected error 
while processing audio buffer 

Try saving then closing and reopening the project. 

12 
[Internal] Internal audio buffer 
memory limit overflow 

Contact support with recipe/project file. 

13 
ASIO subsystem signaled a 
dropout due to a state change 

Don’t make changes to ASIO driver during 
playback. Another app may be using driver. 

14 
[Internal] WASAPI 
ReadDataBuffer timed out 

WASAPI device error - restart device or close other
applications using it. 

15 
[Internal] WASAPI buffer 
underrun 

WASAPI device error - restart device or close other
applications using it. 

16 
[Internal] WASAPI Read/Write 
buffer failed 

WASAPI device error - restart device or close other
applications using it. 

17 
WASAPI device removed or 
unavailable 

The device was unplugged. Re-attach device. 

Note: Dropout reason codes can be used for better diagnostics. Please contact Cakewalk Support 
and mention the dropout code if you are experiencing persistent audio engine dropouts that you are 
unable to remedy on your own. 

For more information about dropouts, click here.
  

Live performance enhancements 

This release includes a few enhancements that can be helpful when using Cakewalk in a live 
performance. 
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Option for Play List to close projects regardless of project changes 

When using the Play List, the new File > Discard Project Changes During Playback option 
allows the Play List to automatically discard any changes before loading the next song. This lets 
you make minor temporary changes during playback, such as adjusting levels, without being 
prompted to save the changes before loading the next song. During playback, the Play List will 
ignore a project's modified state and close without saving. This option is enabled by default. 

Note: This option is only active during (Play List) playback. Cakewalk will always prompt to save 
a modified project if playback is stopped.

  

Option for Play List to preload the next song during playback 

By default, the Play List loads the next song while the current song is playing. While this can save 
time before the next project starts playing, it may cause glitches when loading large complex 
projects projects during playback. 

To defer loading the next song until playback of the current song has finished, disable the File > 
Preload Next Song During Playback option. 

  

Automatically stop/pause playback with MCI MIDI events 

You can instruct Cakewalk to stop or pause playback at a defined moment, so you can start 
playback again manually. This can be very useful in a live setting. 

This is done by inserting an MCI Command event in a MIDI track’s Event List view (ALT+8), and 
assigning the MCI Commands value to either stop or pause: 

stop  - stops the transport and returns to zero
pause - pauses the transport allowing you to manually continue playback from where you left off 

https://discuss.cakewalk.com/uploads/monthly_2019_10/image.png.7505eb2fc385004e3888c552479291f7.png


Press Play (SPACEBAR) manually to resume playback.

  

Improved compatibility with older SONAR WRK files 

We continue to improve backwards compatibility with older Cakewalk products. Older SONAR 
.WRK files that contain automation or reference MCI audio events will now load properly in 
Cakewalk.

https://discuss.cakewalk.com/uploads/monthly_2019_10/image.png.1d1365200dbe18304e58d31aea67dfdc.png

